Back to overview
Resolved
Application issue while saving drafts
Sep 8, 2026 at 7:15pm UTC
Affected services
Applications
Resolved
Sep 10, 2026 at 6:10am UTC
Applications are saving normally again!
Affected services
Created
Sep 8, 2026 at 7:15pm UTC
Application saving is currently downgraded due to a issue.
Affected services