Back to overview
Resolved
Applications were paused
Sep 8, 2026 at 6:00am UTC
Affected services
Applications
Resolved
Sep 8, 2026 at 4:00pm UTC
We deployed a fix for the Management Opportunity issue!
A fix has been issued and members notified.
Affected services
Created
Sep 8, 2026 at 6:00am UTC
We paused applications for the Management Opportunity due to a issue with auto fill.
Affected services